Skip to content

Mudlet Scripting



  • edited June 2016
    Oh.  Wait.  So, I would have to be using something that allows me to "look" at the room as if I were IN the room with the person then (like SHARD OBSERVE, or uh, MIND GLANCE).  And then, the mapview is probably the only place to get the room number, if I understand right.  Thanks.  

    It works.  Neat.  
  • Here's how to report it.

    Make a trigger with fire length two.

    You extend your eyesight, empowered by the pure Diachaim, to seek out the location of -- beginning of line substring,

    Make another trigger with fire length one and put this inside the above trigger.

    ^([^\.]+)\.$ -- perl regex

    doppieroomname = matches[2]

    Make a third trigger and put that inside the above trigger.

    v(\d+) -- perl regex

    doppieroomnum = matches[2]

    if doppieroom == true and raid == true then

    send("rt [BATS]: " .. .. " at " .. doppieroomname .. " #" ..doppieroomnum)




    highlighttimerroom = tonumber(doppieroomnum)

    doblink( highlighttimerroom )


    To capture enemy room number locations of farsight and similar abilities and blink the room.
  • How do I transfer my Imperian system to my new laptop?

    I tried to Save Profile As but I couldn't get it to import. I was also told it's a .config file, but it the upload I tried failed on dropbox (after 3 hours of waiting for it to upload).
    (Ring): Lartus says, "I heard Theophilus once threw a grenade and killed ten people."
    (Ring): Lartus says, "Then it exploded."

    (Ring): Zsetsu says, "Everyone's playing checkers, but Theophilus is playing chess."
  • Theo, I do this the super technical way.  First, I made sure I could see all hidden files and folders.  Then, I move stuff into new folders in the same spot on my new computer.  If there isn't a folder with quite the same name, I make one.   

    (folder) C:\Users\Rhoda\.config\mudlet
    (folder) C:\Users\Rhoda\AppData\Local\Mudlet
    (file)  C:\Users\Rhoda\mudlet-data

    And of course I made a new shortcut to open the application from my desktop.  

  • How do I transfer my Imperian system to my new laptop?

    I tried to Save Profile As but I couldn't get it to import. I was also told it's a .config file, but it the upload I tried failed on dropbox (after 3 hours of waiting for it to upload).

    Like @Jules said, literally the easiest way is just to copy over the entire "Imperian" folder in your mudlet profile directory and drop it into your new machine. Failing that, you can export everything as a .xml file and re-import it, but that's sort of a pain. (Your profile is really just a giant .xml file anyway.)
  • How do I make an alias that contains quotations marks in it?
  • edited July 2016
    Why do you want quotation marks in an alias? You should still be able to include them the same way, though. ^"alias"$
  • edited October 2016
    I have a very serious mapper problem. Mudlet had been working fine on Windows 10, until I installed the most recent updates - even with clean mudlet installs. I tried both 2.1 and 3.0, and manually deleted all extra files, including the .config folder, the Mudlet folder in AppData/Local, and the mudlet-data file that is created at in the User's folder. 3.0 installs a bunch of stuff in a program files folder, and seems to do a fine job of deleting those with its uninstall feature (but I do manually clean out everything else). GMCP was enabled in both cases, with a restart, and I also updated mudlet mapper. There is also a compatibility feature for Windows if you right click on the program you want to open, and I tried running both versions in Windows 8 mode.

    Here is what I see in the map.xml file that downloads when I hit the "Map" icon and the system downloads the map:

    <html> <head><title>301 Moved Permanently</title></head> <body bgcolor="white"> <center><h1>301 Moved Permanently</h1></center> <hr><center>nginx/1.10.1</center> </body> </html>

    I tried manually replacing the xml file with the correct file from here:

    but I don't think the Mudlet works that way. You can certainly replace the map.xml file, but Mudlet doesn't seem to see it when you do. This lack of an ability to manually manipulate files seems to be a gripe on mudlet forums, but it is what it is. As well, Mudlet seems unable to create the "map" folder which is where all of the dbt files are stored (I don't know the exact relationship between the xml and dbt files, other than that dbt maybe does something something databasey to the xml files, maybe...).

    As well, when I hit Mudlet's pesky "click here to remove the reminder" for updating maps, I got this:

    Lua error:[string "mmp.updatedmap('<html>..."]:1: unfinished string near ''<html>'

    So then, I restored my system to get rid of the updates, and essentially did all of the same things. There are slight differences in what happens, but no better outcome. Now, Mudlet saves the same content in map.xml as above, but doesn't even seem to recognize that I have a map.xml file at all in 2.1 - so it prompts me to download the map every time. In 3.0, it knows it has an xml file, but when it prompts me to "update" it, nothing happens when I try to remove the reminder (not even the Lua error).

    So in short, I could probably dig up some older dbt files and xml files and I bet I could have some kind of map again, but I can't update. Period.
  • edited October 2016
    Actually. It might not just be me and my upgrade. I thought I'd at least get myself a new map by using an old profile on an older comp that is still Windows 8.1. I used the old faithful tactic of "go to profile, delete map.xml, delete "map" folder, open mudlet, click on "map" button and download fresh map" but all is not well. I had the same problem on an old, reliable profile, on an old, reliable OS that has always worked fine. That said, I don't know xml, but the current map.xml that I downloaded last night does pass w3schools' xml checker with no problems.

    EDIT: going to tag @Ultrix here, because she's the only person who I know for a fact actually cares about up to date maps. Curious how it's working for her.
  • MathiausMathiaus Pennsylvania
    I actually have a map.dat file to load in for mudlet if you would like the file.
  • edited October 2016
    I am now wondering why I said dbt. At one point in all of this, I think some of the files had a dbt extension rather than a dat extension now that I think about it, which could maybe be unsettling... Still, none of that touched my old comp, and it isn't able to download a fresh map either.

    I do have some old-ish map.dat files in various folders. Not sure if you mean those, Mathiaus, or... I guess people also create them through manual mapping. What usually happens on a vanilla map-wipe and re-download is, I get a fresh map.xml from Imperian, and (I am guessing through the magic of database thingies) Mudlet creates a new dat file in the map folder at the same time. This one is super old, but for example "03-02-2016#22-39-09map.dat".
  • MathiausMathiaus Pennsylvania
    I actually saved out my map before in the mapper tab. I load it in when I have to reinstall sometimes.

    I regularly run around with mconfig toggled to auto map, and if there is a room that actually needs manually added, you just do the alias rlc <direction> and it'll add that room.
  • edited October 2016
    I have never been able to get the manual mapper to work for me. Even with the step by step instructions. There is just something about the way that coders write instructions. I am SUPER careful about following instructions, and making sure I understood them correctly, and in real life people always bug me to help them with their security system where it turns out they installed all of the sensors backwards because they didn't read carefully, or to help put up a shed with "okay" but less than great instructions (and all of the pieces MUST be carefully put together in a certain order to be absolutely correct). Or figure out all sorts of things that have instructions that have to be read carefully and possibly need to be thought through as well. But as much as I love Vadi (and I knew Vadi), he's a typical coder who writes typical coder instructions, and I end up going "wtf, this doesn't work, and I've spent 3 hours trying to figure out and I have no idea wtf he is saying". At the same time, coders weirdly miss very, very basic statements in narrative, and I wonder if this is part of the problem. It is almost like they CAN'T operate in a narrative way.

    Anyway, I appreciate it, but the game map is honestly great so long as people like Ultrix push push push them to fix areas that are actually mapped, but broken in some way (I wonder how many years people stumbled around Byley plains, for example). I wish I'd been able to get the Aetolian admin to be nearly as responsive about fixing clearly broken map areas (work just fine with in game map, but downloaded map doesn't work)... I just want to figure out why I am suddenly unable to download a fresh one on any comp.
  • MathiausMathiaus Pennsylvania
    It just started happening to me too. The mapper download doesn't work.
  • All the sites have recently been switched to https - mudlet likely does not support it.
  • @Kiskan and @Mathiaus - does the game map still error out if you try to download/use it on a clean/new mudlet profile?
  • edited October 2016
    @Ultrix - yeah, check out my crazy list of "things tried with exacting precision" :(

    Hmm. I would say that this is the perfect time for me to reconsider the web client. But reading the thread about 2.8, I still feel like my choices would be to either deal with JavaScript (hahahaha no, I saw the "simple" example in that one thread and there is no way I am EVER using JavaScript for ANYTHING) or, an overly simplified thingy that won't do even the stuff I have learned to do. The Nexus client splits people into such extremes. It is either "know this incredibly fussy and difficult language" or "click boxes lol".

    EDIT: I mean, there are a small number of "coding" commands, but I have doubts it's enough. And the worst part would be, getting to the point where you are ready to do more, and not being able to without... yep, learning JavaScript. Hell no.
  • edited October 2016
    As Garryn said, they've been changed to https; you will have to download 3.0 version of mudlet in order to download them now, as 2.1 does not support downloading from https websites, whereas 3.0 does.
  • I downloaded a clean copy of 3.0 as well (first post). That didn't work either. Any of the times I tried it :/
  • MathiausMathiaus Pennsylvania
    edited October 2016
    I'll up load a link to my dat file later
  • edited October 2016
    Maybe @Mathiaus and @Dicene could try downloading the map.xml on clean installs of 3.0 if they haven't already then... I guess maybe if it doesn't work properly for them either, we could try to bug it with whoever is tinkering with Mudlet these days. The Achaeans might know something too, although I haven't seen any chatter about this particular issue on their forums yet (there were some people with mapper issues waaaaay earlier in the year, but I think that was something else). I'd sure hate for the current, updated game map to become permanently nonexistent for/invisible to the most popular client.
  • Well damn :(

    It's low priority too (and that was probably appropriate before all of the maps were https I guess). Ugh. It probably wouldn't hurt if a few people chimed in. If this affects you and you care about getting some attention directed towards fixing it, you want to follow the above link, log in, and mark that the the bug DOES affect you in the provided drop down menu (need to be logged in). It also helps if you SUBSCRIBE to notifications. Both of those things boost the bug's "Bug Heat" score. Comments are good, but I bet we get the best results if we do the other things, too.
  • edited October 2016
    Good news. A dude found the problem in the backend of the mapper, and it seems pretty straightforward (even to me). But the Mudlet guys still have to decide it's worth fixing. If they do, it means there will be nice clean new maps for us all day every day again (at least on 3.0 delta).

    It might not feel like a big deal this second, but it gets pretty sucky to not just have the latest map right from the game's server, especially since so much effort has gone into making those maps solid and up to date. It would be such a waste. Sure, hopefully Math will post his files, and I (probably) still have some relatively recent ones lying about somewhere, but I don't want to go back to operating like that - "oh, someone posted their map awhile back, it still works pretty good most places". It's so 2006 :(

    EDIT: as an aside, I wonder how people who use other clients are affected. Mudlet is by far the most popular client, and even its "Outdated" 2.1 version (which is still in very, very heavy use I think) is still far newer than most other clients people use. Then again, Mudlet just doesn't let the user have any real control over where the maps get downloaded from, so if it can't grab the map from the EXACT place it's expecting to grab it, you're toast. Maybe other clients are more flexible?
  • MathiausMathiaus Pennsylvania
    I feel you bro
  • Just wait until the shade gets a hold of the maps. It will be httpssssssssssssssssssssss >.>
  • MathiausMathiaus Pennsylvania

    Have to mess around with mconfig to get areas I working off the bat I think. Otherwise, all you have to do is load file in the mapper tab and you'll be good to go.
  • edited October 2016
    So far, my profile works fine on 3.0. I literally just popped it in the "current" folder and loaded it up. I am leery of any pitfalls. Are there any that people have come across? I know about stuff like audio files not working but I just mean, did anything break if you lazily moved "03-10-2016#11-18-12.xml" from your 2.1 folder to your 3.0 folder and just hoped it would work? Or is that secretly what everyone does, and that is pretty much the full extent of "upgrading to 3.0" (I will die if this is the case).

    EDIT; also, that map worked fine, thanks.
  • We're working on a TEMPORARY workaround for this, which should be deployed this evening. I want to stress that this is a SHORT-TERM workaround to allow HTTP fetching for just the maps, in an attempt to support clients that don't properly support SSL. It won't be around forever.

    Somewhat more on topic with the thread: it looks like a proper fix to the SSL bug is in the current source tree for Mudlet 3.0, but not in the distributed binaries yet.
    Like what we're doing? Why not take a second to vote? Vote for Imperian at
  • edited October 2016
    This is now live, map syncing should work once again.
    Like what we're doing? Why not take a second to vote? Vote for Imperian at
  • The binaries on their site are unfortunately like, 9.5 years old. I could compile straight from the dev tree source for Windows if people would like the latest possible release, although there could be bugs(probably no more than 3.0 delta).

    I also have a slightly modded version that prints errors to the main window instead of just to the errors tab in the script window. It also lets you use CTRL+S to save whatever alias/trigger/script you're working on. I've had issues with the search tab in the editor clearing scripts, but that could be a lingering bug from 3.0-dev, and might not be my fault(I don't know how any of my changes could have possibly caused that issue).

    If there's interest I'll post one or both here for people to use until 3.0 eventually gets another official release.
Sign In or Register to comment.